Задать вопрос
26 января, 13:42

Даны натуральные числа m и n (m
составить программу, печатающую все натуральные числа больше m, но меньше n, а также сумму этих чисел.

в программе Паскаль

+1
Ответы (1)
  1. 26 января, 14:33
    0
    Var m, n, i, s:integer;

    begin

    write ('m = ') ;

    readln (m) ;

    write ('n = ') ;

    readln (n) ;

    s:=0;

    for i:=m+1 to n-1 do

    begin

    write (i,' ') ;

    s:=s+i;

    end;

    writeln;

    writeln ('s = ', s) ;

    end.

    Пример:

    m = 5

    n = 10

    6 7 8 9

    s = 30
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны натуральные числа m и n (m ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Это цикл for: 1) даны натуральные числа X и Y. вычислить X*Y, пользуясь только оперцией сложения. 2) даны натуральные числа X и Y. вычислить X^Y 3) дано натуральное число N. найти сумму S=1+1/2+1/3 + ... + 1/N. 4) дано натуральное число N и число Х.
Ответы (1)
Программа на с++ Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a, b ], делящиеся на каждую из своих цифр.
Ответы (1)
Даны натуральные числа a и b, обозначающие соответственно числитель и знаменатель дроби. Сократить дробь, т. е. найти такие натуральные числа p и q, не имеющие общих делителей, что p/q=a/b.
Ответы (1)
Даны натуральные числа m и n. Получить все натуральные числа, меньшие n, квадрат суммы цифр которых равен m.
Ответы (1)
1) Даны два целых числа A и B (A < B). Найти сумму квадратов всех целых чисел от A до B включительно. 2) Даны натуральные числа от A до B (A
Ответы (1)