Задать вопрос
28 февраля, 00:36

Даны натуральные числа m и n. Получить все натуральные числа, меньшие n, квадрат суммы цифр которых равен m.

+5
Ответы (1)
  1. 28 февраля, 04:35
    0
    begin s1:=copy (s, 1, pos (' ', s) - 1) ; {копируем первое слово до пробела} for i:=pos (' ', s) + 1 to length (s) do{смотрим строку дальше} if (copy (s, i, length (s1)) = s1) {если набор символов совпадает с этим словом} and (s[i-1]=' ') {и перед ним пробел} and ((s[i+length (s1) ]=' ') {и за ним пробел} or (i+length (s1) - 1=length (s))) then{или это последнее слово} begin k:=1; {фиксируем совпадение} s2:=s1; {запоминаем слово} write ('Одинаковые слова ', s2) ; {выводим на экран} readln; exit; {выходим из программы, нужно только 1 пару} end; delete (s, 1, pos (' ', s)) ; {удаляем первое слово, следующее первое} end; if k=0 then write ('Нет двух одинаковых слов') ; readln end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны натуральные числа m и n. Получить все натуральные числа, меньшие n, квадрат суммы цифр которых равен m. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Даны натуральные числа m, n. Получить все кратные им числа, меньшие m*n. сделать на паскале)
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Программа на с++ Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a, b ], делящиеся на каждую из своих цифр.
Ответы (1)
1. Даны натуральные числа a и b. Определить все числа, кратные a и b, меньшие a*b (a и b должны быть больше 10). На питоне
Ответы (1)