Задать вопрос
10 июля, 12:30

Составить программу на Паскале. В массиве хранится информация о стоимости каждой из M книг. Определить количество самых дешевых книг (с одинаковой минимальной ценой)

+5
Ответы (1)
  1. 10 июля, 13:51
    0
    Var mas:array of integer; min, kol, j, i, n:integer;

    begin

    Randomize; min:=0; kol:=0;

    write ('n:') ;

    readln (n) ;

    setlength (mas, length (mas) + n) ; / / / динамический массив вы можете заменить на статический

    For i: = 0 to high (mas) do

    mas[i]:=Random (50) ;

    min:=mas[0];

    for j:=0 to high (mas) do//ищем минимальную ценну

    if min>mas[j] then

    min:=mas[j];

    For i: = 0 to high (mas) do

    if min=mas[i] then//ищем количество книг с минимальной ценой

    inc (kol) ;

    write ('kolvo min ', kol) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на Паскале. В массиве хранится информация о стоимости каждой из M книг. Определить количество самых дешевых книг (с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Люди, хеелп Сортировка массива (метод пузырька; метод простого выбора). В массиве хранится информация о стоимости каждой из 50 книг. Вывести на экран стоимости 10 самых дешевых книг. паскаль.
Ответы (1)
В массиве хранится информация о стоимости каждой из 50 книг. Вывести на экран стоимости 10 самых дешевых книг.
Ответы (1)
В массиве хранится информации о стоимости каждой из 60 книг. Определить количество самых дешёвых книг.
Ответы (1)
В паскале. В массиве хранится информация о стоимости каждого из 50 марок легковых автомобилей Определить, сколько стоит самый дорогой автомобиль.
Ответы (1)
Написать программу в с# двумерный массив В двумерном массиве хранится информация о количестве учеников каждом из четырех классов каждой параллели школы с первой по одиннадцатую (в первой строке - информация о первых классах, во второй - вторых и т.
Ответы (1)