Задать вопрос
19 мая, 00:12

В массиве хранится информация о стоимости каждой из 50 книг. Вывести на экран стоимости 10 самых дешевых книг.

+3
Ответы (1)
  1. 19 мая, 00:56
    0
    const n=50;

    var

    a:array[1 ... n] of integer;

    m, i, j:integer;

    begin

    randomize;

    for i:=1 to n do begin

    a[i]:=random (3600) + 300;

    write (i,'. ', a[i]) ;

    end;

    for j:=1 to n-1 do begin

    for i:=1 to n-1 do

    if a[i]>a[i+1] then begin

    m:=a[i];

    a[i]:=a[i+1];

    a[i+1]:=m;

    end;

    end;

    writeln;

    for i:=1 to 10 do writeln (i,') ', a[i]) ;

    end.

    То-что курсивом это организация ввода в массив цен. Если у вас другой способ то измените. 3600 это max цена, а 300 min можно и тут поменять. Как угодно)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве хранится информация о стоимости каждой из 50 книг. Вывести на экран стоимости 10 самых дешевых книг. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Люди, хеелп Сортировка массива (метод пузырька; метод простого выбора). В массиве хранится информация о стоимости каждой из 50 книг. Вывести на экран стоимости 10 самых дешевых книг. паскаль.
Ответы (1)
Составить программу на Паскале. В массиве хранится информация о стоимости каждой из M книг. Определить количество самых дешевых книг (с одинаковой минимальной ценой)
Ответы (1)
В массиве хранится информации о стоимости каждой из 60 книг. Определить количество самых дешёвых книг.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)