Задать вопрос
9 июля, 23:37

Помогите решить в Паскале

Вычислить: у=1-1/1!+1/2!-1/3! + ... 1/n!. Значение n задать вводом

+1
Ответы (1)
  1. 10 июля, 01:34
    0
    Var

    n, i:integer;

    s:real;

    begin

    s:=1;

    readln (n) ;

    for i:=1 to n do

    if i mod 2 = 1 then

    s:=s-i*ln (2)

    else

    s:=s+i*ln (2) ;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить в Паскале Вычислить: у=1-1/1!+1/2!-1/3! + ... 1/n!. Значение n задать вводом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите составить программу в Паскале. Составить программу, формирующую массив из 10 дробных чисел вводом с клавиатуры и находящую суму всех его элементов.
Ответы (1)
написать на Паскале условие задачи №2: ввод с клавиатуры последовательности чисел заканчивается вводом нуля, найти произведение этих чисел, нуль в последовательность не входит.
Ответы (1)
написать программу на Паскале: "ввод с клавиатуры последовательности чисел заканчивается вводом нуля, найти произведение этих чисел, нуль в последовательность не входит"
Ответы (1)
Составить программу, формирующую массив из 10 дробных чисел вводом с клавиатуры (см. пример) и находящую сумму всех его элементов. Ответ написать как пишут в паскале.
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)