Задать вопрос
19 июня, 22:02

написать на Паскале условие задачи №2: ввод с клавиатуры последовательности чисел заканчивается вводом нуля, найти произведение этих чисел, нуль в последовательность не входит.

+2
Ответы (1)
  1. 20 июня, 00:22
    0
    Program Chisla;

    Uses Crt;

    var p, c:real;

    begin

    clrscr;

    write ('Введите числа конец ввода 0:') ;

    p:=1;

    repeat

    readln (c) ;

    if (c=0) then break

    else p:=p*c;

    until (c=0) ;

    writeln ('Произведение чисел = ', p) ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать на Паскале условие задачи №2: ввод с клавиатуры последовательности чисел заканчивается вводом нуля, найти произведение этих чисел, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
написать программу на Паскале: "ввод с клавиатуры последовательности чисел заканчивается вводом нуля, найти произведение этих чисел, нуль в последовательность не входит"
Ответы (1)
Паскаль: Дана последовательность целых чисел, ввод последовательности заканчивается 0 (до первого введенного нуля), найти среднее арифметическое чисел из последовательности
Ответы (1)
Написать программу, которая обеспечивает ввод последовательности чисел. Количество чисел в последовательности неизвестно. Признаком конца последовательности является ввод 0.
Ответы (1)
написать программу на Паскале: "найти номер первого максимального элемента во вводимой с клавиатуры последовательности чисел. Условие окончания ввода - ввод числа 0."
Ответы (1)
Как это решать? И что тут вообще надо сделать? A+B Ограничение времени 1 секунда Ограничение памяти 64Mb Ввод стандартный ввод или input. txt Вывод стандартный вывод или output. txt Даны 2 числа a и b. Найти сумму этих чисел.
Ответы (1)