Задать вопрос
29 февраля, 02:01

Паскаль: Дана последовательность целых чисел, ввод последовательности заканчивается 0 (до первого введенного нуля), найти среднее арифметическое чисел из последовательности

+3
Ответы (1)
  1. 29 февраля, 04:41
    0
    Var temp, sum, n:integer;

    begin

    sum:=0;

    n:=0;

    read (temp) ;

    while (temp>0) do

    begin

    inc (sum, temp) ;

    inc (n) ;

    read (temp) ;

    end;

    writeln;

    writeln (sum/n)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль: Дана последовательность целых чисел, ввод последовательности заканчивается 0 (до первого введенного нуля), найти среднее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Дана последовательность случайных натуральных чисел, лежащих в диапазоне от 1 до 255. Конец последовательности число 0. Определить среднее арифметическое элементов последовательности.
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Это в Паскале. Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел, количество которых заранее не известно.
Ответы (1)
Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.
Ответы (1)