Задать вопрос
4 мая, 23:32

Написать цикл на паскале, который составляет матрицы (размеры - n рядков, m-столбцов) заполненные сверху вниз числами от 1 до n*m (пример) :

1 4 7

2 5 8

3 6 9

+1
Ответы (1)
  1. 5 мая, 01:55
    0
    Var n, m, i, j, k:integer;

    begin

    read (n, m) ;

    for i:=1 to n do

    begin

    k:=i;

    writeln;

    for j:=1 to m do

    begin

    write (k,' ') ;

    k:=k+n;

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать цикл на паскале, который составляет матрицы (размеры - n рядков, m-столбцов) заполненные сверху вниз числами от 1 до n*m (пример) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Ввести матрицу. Найти сумму четных элементов матрицы. Если она отрицательна, то заменить элементы четных столбцов матрицы на 1, в ином случае нечетных столбцов на - 1. Матрицу распечатать
Ответы (1)
Запишите имя блока, который образуется пересечением: 1) столбцов C, D, E со строками 5, 6, 7, 8; 2) столбцов F, G со строками 1, 2, 3; 3) столбцов B, C, D, E со строками 9,10.
Ответы (2)
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)
Если в прямоугольной матрице меньше половины столбцов содержит отрицательные элементы, то все элементы с нечетными номерами столбцов умножить на 10. В противном случае все отрицательные элементы матрицы возвести в квадрат.
Ответы (1)