Задать вопрос
14 марта, 23:44

Двумерный целочисленный массив порядка 10x10 заполняется случайными числами. Найти: произведение элементов главной и побочной диагонали

+1
Ответы (1)
  1. 15 марта, 00:03
    0
    Const n=10;

    var

    a:array[1 ... n, 1 ... n] of integer;

    i, j:integer; p1, p2:real;

    begin

    Randomize;

    writeln ('Исходный массив:') ;

    for i:=1 to n do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=random (20) ;

    write (a[i, j]:4) ;

    end;

    writeln;

    end;

    p1:=1; p2:=1;

    for i:=1 to n do

    begin

    p1:=p1*a[i, i];

    p2:=p2*a[i, n-i+1]

    end;

    writeln ('p1 = ', p1,' p2 = ', p2) ;

    end.

    Пример (для n=5) :

    Исходный массив:

    1 10 14 0 5

    12 13 13 5 0

    7 7 8 7 14

    5 11 3 17 14

    12 1 19 17 10

    p1 = 17680 p2 = 26400
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Двумерный целочисленный массив порядка 10x10 заполняется случайными числами. Найти: произведение элементов главной и побочной диагонали ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
2. Задать двумерный массив (4 х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы. 3. Задать двумерный массив (7 х7) случайными значениями от 12 до 18 включительно.
Ответы (1)
Перед вами часть кода программы на языке Pascal. sum:=0; for i:=1 to n do for j:=1 to n do if (i
Ответы (1)
Дан целочисленный двумерный массив a (n, n) n=6. Найти среднее геометрическое элементов побочной диагонали и поставть его на место максимального элемента главной диагонали.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)