Задать вопрос
14 октября, 14:11

Дан целочисленный двумерный массив a (n, n) n=6. Найти среднее геометрическое элементов побочной диагонали и поставть его на место максимального элемента главной диагонали.

+5
Ответы (1)
  1. 14 октября, 14:46
    0
    Program ANT;

    const n=6; m=6;

    var i, j:integer;

    var a:array [1 ... n, 1 ... m] of real;

    begin

    writeln ('Введите матрицу') ;

    for i:=1 to n do

    for j:=1 to m do begin

    writeln ('a[', i,',', j,']') ;

    readln (a[i, j]) ;

    end;

    writeln ('Исходная матрица') ;

    for i:=1 to n do

    for j:=1 to m do begin

    writeln (a[i, j]) ;

    writeln;

    end;

    u:=0;

    for i:=1 to n do begin

    for j:=1 to m do

    if i+j=7 then u:=u+ln (a[i, j]) ;

    end;

    writeln ('Среднее геометрическое', u) ;

    max:=[1,1];

    for i:=1 to n do begin

    for j:=1 to m do

    if (a[i, j]>max) then [i, j]:=max;

    end;

    writeln ('Максимальное значение', max) ;

    u:=max;

    writeln ('Полученная матрица') ;

    for i:=1 to n do

    for j:=1 to m do begin

    writeln (a[i, j]) ;

    writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный двумерный массив a (n, n) n=6. Найти среднее геометрическое элементов побочной диагонали и поставть его на место ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
Перед вами часть кода программы на языке Pascal. sum:=0; for i:=1 to n do for j:=1 to n do if (i
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)