Задать вопрос
9 июня, 04:27

1. Дана непустая последовательность целых чисел, оканчивающаяся нулем. Найти сумму всех чисел последовательности.

Паскаль

+2
Ответы (1)
  1. 9 июня, 08:18
    0
    Var

    number: integer;

    sum, product, k: integer;

    begin

    repeat

    write ('number = ') ;

    readln (number) ;

    sum : = sum + number;

    until number = 0;

    writeln ('S = ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дана непустая последовательность целых чисел, оканчивающаяся нулем. Найти сумму всех чисел последовательности. Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
1. Дано натуральное n-значное число. Верно ли, что сумма его цифр больше 10. 2. Дана непустая последовательность целых чисел, оканчивающаяся нулем. Найти сумму всех чисел последовательности.
Ответы (1)
Дана непустая последовательность положительных целых чисел a1, a2, ... оканчивающаяся нулем. Получить a1, a1*a2, a1*a2*a3 ... 0 Решить, используя оператор until repeat либо while (паскаль)
Ответы (1)
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)
Написать программу в паскале, используя repeat until. Задача: Дана непустая последовательность, оканчивающаяся нулем. Найти в ней минимальную цифру.
Ответы (1)