Задать вопрос
18 июня, 08:23

Дана непустая последовательность положительных целых чисел a1, a2, ... оканчивающаяся нулем. Получить a1, a1*a2, a1*a2*a3 ... 0

Решить, используя оператор until repeat либо while

(паскаль)

+5
Ответы (1)
  1. 18 июня, 10:54
    0
    Program p1;

    var a, b: integer;

    begin

    repeat r

    ead (a) ;

    b : = b * a;

    write (b, ' ') until b = 0;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана непустая последовательность положительных целых чисел a1, a2, ... оканчивающаяся нулем. Получить a1, a1*a2, a1*a2*a3 ... 0 Решить, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу в паскале, используя repeat until. Задача: Дана непустая последовательность, оканчивающаяся нулем. Найти в ней минимальную цифру.
Ответы (1)
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
1. Дана непустая последовательность целых чисел, оканчивающаяся нулем. Найти сумму всех чисел последовательности. Паскаль
Ответы (1)
1. Дано натуральное n-значное число. Верно ли, что сумма его цифр больше 10. 2. Дана непустая последовательность целых чисел, оканчивающаяся нулем. Найти сумму всех чисел последовательности.
Ответы (1)
1) Какие операторы используются для организации циклов? a) while условие until; b) repeat until условие; c) while условие do; d) repeat do условие.
Ответы (1)