Задать вопрос
1 февраля, 06:04

Написать программу в паскале, используя repeat until. Задача: Дана непустая последовательность, оканчивающаяся нулем. Найти в ней минимальную цифру.

+2
Ответы (1)
  1. 1 февраля, 06:30
    0
    var x, min:integer;

    begin

    min:=999999;

    repeat

    readln (x) ;

    if (min>x) and (x0) then min:=x;

    until x=0;

    writeln (min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в паскале, используя repeat until. Задача: Дана непустая последовательность, оканчивающаяся нулем. Найти в ней ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана непустая последовательность положительных целых чисел a1, a2, ... оканчивающаяся нулем. Получить a1, a1*a2, a1*a2*a3 ... 0 Решить, используя оператор until repeat либо while (паскаль)
Ответы (1)
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
1. Дано натуральное n-значное число. Верно ли, что сумма его цифр больше 10. 2. Дана непустая последовательность целых чисел, оканчивающаяся нулем. Найти сумму всех чисел последовательности.
Ответы (1)
1. Дана непустая последовательность целых чисел, оканчивающаяся нулем. Найти сумму всех чисел последовательности. Паскаль
Ответы (1)
1. На входе непустая последовательность натуральных чисел с нулем в конце. Вывести MIN и среднее арифметическое. Представить блок-схему и pascal-программу. 2. На входе последовательность вещественных чисел с нулем в конце.
Ответы (1)