Задать вопрос
22 февраля, 23:30

Дана непустая последовательность целых чисел, оканчивающаяся нулем

(0 является признаком окончания последовательности и в последовательность не входит).

Найти и напечатать:

1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).

Если таких чисел нет, то напечатать "Таких чисел нет"

2. Количество четных чисел

+1
Ответы (1)
  1. 23 февраля, 03:25
    0
    Var

    a:array[1 ... 1000] of longint;

    i, j, k, b, h, v:longint;

    begin

    i:=2;

    readln (a[1]) ;

    while (a[i-1]0) do begin readln (a[i]) ; inc (i) ; end;

    readln (j) ;

    for k:=1 to i-1 do

    if a[k]>j then h:=h+a[k] else inc (b) ;

    if b=i-1 then writeln ('Takix 4isel netu') ;

    for k:=1 to i-1 do

    if a[k] mod 2=0 then inc (v) ;

    writeln (h, ', v) ;

    end.

    ну при компиляции могут быть ошибки, т. к. писал сразу здесь ... но суть задачи и её решение я вижу именно так
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано натуральное n-значное число. Верно ли, что сумма его цифр больше 10. 2. Дана непустая последовательность целых чисел, оканчивающаяся нулем. Найти сумму всех чисел последовательности.
Ответы (1)
1. Дана непустая последовательность целых чисел, оканчивающаяся нулем. Найти сумму всех чисел последовательности. Паскаль
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)
Определите сумму всех элементов последовательности, завершающейся числом 0. Числа, следующие за нулем, считывать не нужно. Входные данные Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит).
Ответы (1)