Задать вопрос
7 февраля, 19:50

Заданы координаты трех вершин треугольника (х1, у1), (х2, у2), (х3, у3). найдите его периметр и площадь. нужно написать в паскале

+2
Ответы (1)
  1. 7 февраля, 20:02
    0
    Program q2; var x1, x2, x3, y1, y2, y3, a, b, c, P, S: real; begin readln (x1) ; readln (x2) ; readln (x3) ; readln (y1) ; readln (y2) ; readln (y3) ; a=sqrt ((x2-x1) * (x2-x1) + (y2-y1) * (y2-y1)) ; b=sqrt ((x3-x2) * (x3-x2) + (y3-y2) * (y3-y2)) ; c=sqrt ((x1-x3) * (x1-x3) + (y1-y3) * (y1-y3)) ; P=a+b+c; S=sqrt ((0,5*P) * (0,5*P-a) * (0,5*P-b) * (0,5*P-c)) ; writeln (P) ; writeln (S) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заданы координаты трех вершин треугольника (х1, у1), (х2, у2), (х3, у3). найдите его периметр и площадь. нужно написать в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Прямоугольник. Зная координаты трех вершин прямоугольника на координатной плоскости, определить координаты четвертой вершины. Входные данные В одной строке записаны шесть чисел - координаты трех вершин прямоугольника.
Ответы (1)
Заданы координаты трех вершин треугольника. Найти его периметр и площадь.
Ответы (1)
Даны координаты трех вершин треугольника. Найти его площадь. Пример. Для вершин (0.0) ; (0,1) ; (1,0) площадь - 0,5.
Ответы (1)
Cоставить программу в Паскале: Заданы координаты концов отрезка (x1; y1) и (x2; y2) и два целых числа N1, N2. Вычислить координаты точки (х; у), которая делит отрезок в отношении N1/N2: если L=N1/N2, то х = (х1+L*x2) / (1+L), y = (y1+L*y2) / (1+L).
Ответы (1)
Составить программу на паскале. Заданы длины сторон трех треугольников. Найти больший периметр. Для вычисления периметра треугольника используйте процедуру Perimetr, для определения большего из 2 чисел-процедура max
Ответы (1)