Задать вопрос
20 мая, 22:00

Составить программу на паскале. Заданы длины сторон трех треугольников. Найти больший периметр. Для вычисления периметра треугольника используйте процедуру Perimetr, для определения большего из 2 чисел-процедура max

+2
Ответы (1)
  1. 20 мая, 23:00
    0
    Program prx;

    uses crt;

    Var a, d, c, k, d, g, o, f, v. perimetr1, perimetr2, perimetr3, max:byte;

    Begin

    Writeln ("Введи длины сторон трех треугольников") ;

    Readln (a, d, c, k, d, g, o, f, v) ;

    Perimetr1:=a+d+c;

    Perimetr2:=k+d+g;

    Perimetr3:=o+f+v;

    If perimetr1>perimetr2

    Then max:=perimetr1

    Else if perimetr2>perimetr3

    Then max:=perimetr2

    Else max:=perimetr3

    End;

    End;

    Writeln (max) ;

    Readln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на паскале. Заданы длины сторон трех треугольников. Найти больший периметр. Для вычисления периметра треугольника ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Где ошибка? Sub сер Dim x, y, z, f, max, min As Single x = Val (InputBox (2)) y = (InputBox (6)) z = (InputBox (10)) If x / 2 > y / 3 > z / 4 Then If x / 2 > y / 3 Then max = x / 2 Else max = y / 3 End If End If Else If y / 3 > z / 4 Then max =
Ответы (1)
Паскаль Как написать программу, которая уменьшала бы ВСЕ максимальные элементы в два раза? Так? max:=a[1,1]; if a[i, j] > max then max: = a[i, j]; end; max: = max div 2;
Ответы (2)
Исправить ошибки в паскале program massiv2; type mas=array [1 ... 100] of integer; var a: = Max; i, n, min, max, b : integer; недопустимый символ: = (д/б просто :; неизвесмтное имя типа max) begin writeln ('n=') ; readln (n) ;
Ответы (2)
Составить блок-схему к данному коду Var Min, Max, i, m, n:Integer Begin Readln (n) ; max:=-maxint-1; min:=maxint For I:=1 to n do begin ReadLn (m) ; If (m>max) then max:=m; If (m end; Writeln (max,' ', min) ; End.
Ответы (1)