Задать вопрос
1 марта, 05:34

Cоставить программу в Паскале:

Заданы координаты концов отрезка (x1; y1) и (x2; y2) и два целых числа N1, N2.

Вычислить координаты точки (х; у), которая делит отрезок в отношении N1/N2: если L=N1/N2, то х = (х1+L*x2) / (1+L), y = (y1+L*y2) / (1+L).

+4
Ответы (1)
  1. 1 марта, 09:11
    0
    Program qq;

    uses crt;

    var x1, y1, x2, y2, n1, n2: integer; x, y, L, M, k, b: real; / / чтоб было приятно, возьмём координаты начальных точек - целыми числами.

    begin

    writeln ('Введите координаты первой точки через пробел') ;

    readln (x1, y1) ;

    writeln ('Введите координаты второй токи через пробел') ;

    readln (x2, y2) ;

    writeln ('введите через пробел числа N1 и N2') ;

    readln (n1, n2) ;

    l:=n1/n2; / / далее производится расчет по формулам, данным в задании

    x: = (x1+L*x2) / (1+L) ;

    y: = (y1+L*y2) / (1+L) ;

    writeln ('Координаты искомой точки (', x,'; ', y,') ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Cоставить программу в Паскале: Заданы координаты концов отрезка (x1; y1) и (x2; y2) и два целых числа N1, N2. Вычислить координаты точки ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести с клавиатуры координаты двух точек а и в на плоскости вещественный числа вычислить длину. программу нужно написать в паскале пример, как должно получиться введите координаты точки а 5.5 3.5 введите координаты точки b 1.5 2 длинна отрезка ab=4.
Ответы (1)
1. Cоставить программу вычисления площади круга: S = п (пи) * R^2 2. Cоставить программу вычисления площади треугольника: S=1/2*A*H 1) Выделить целую часть результата.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
Напишите программу в Python 3.3 Напишите программу, которая вводит два целых числа, a и b (a < b), и выводит через пробел 5 случайных целых чисел на отрезке [ a, b ]. Входные данные Входная строка содержит два целых числа a и b, разделённых пробелом.
Ответы (1)