Задать вопрос
5 января, 21:20

Дан массив подсчитать произведения всех элементов массива?

+3
Ответы (1)
  1. 5 января, 22:15
    0
    Program p1;

    Var

    j : Integer;

    A: Array[1 ... 5] of Real;

    P : Real;

    Begin

    Randomize;

    P:=1;

    For j:=1 to 5 do

    Begin

    A[j]:=random (100) ;

    P:=P*A[j];

    End;

    Writeln ('Произведение всех элементов массива А равно: ', P) ;

    End;

    Program p2;

    Var

    j : Integer;

    A: Array[1 ... 5] of Real;

    Min : Real;

    Begin

    Randomize;

    For j:=1 to 5 do

    A[j]:=random (100) ;

    Min:=A[1];

    For j:=2 to 5 do

    If (A[j] < Min)

    Then

    Min:=A[j];

    Writeln ('Значение минимального элемента массива: ', Min) ;

    End;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив подсчитать произведения всех элементов массива? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)