Задать вопрос
28 августа, 06:06

Даны 4 числа, найти наибольшее, если это число является четным увеличить его в 3 раза, иначе оставить без изменения

+1
Ответы (1)
  1. 28 августа, 08:53
    0
    Pascal

    var max:integer;

    var a:array[1 ... 4] of integer;

    begin

    max:=-100000000;

    for var i:=1 to 4 do

    readln (A[i]) ;

    for var i:=1 to 4 do

    if (a[i] > max) then

    max:=a[i];

    If (max mod 2 = 0) then

    max:=max*3;

    write (max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны 4 числа, найти наибольшее, если это число является четным увеличить его в 3 раза, иначе оставить без изменения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать в Pascal. Даны два числа, если второе число отрицательное, необходимо уменьшить первое число в 5 раз, иначе числа оставить без изменения
Ответы (1)
Pascal. Даны 2 числа, если первое больше второго по модулю или 2-е число отрицательное, необходимо уменьшить первое число в 5 раз, иначе числа оставить без изменения.
Ответы (2)
Задано число, проверить, если число положительное то его нужно удвоить, если число отрицательное уменьшить в 2 раза, иначе оставить без изменения.
Ответы (2)
Даны действительные числа x, y, z Если все числа положительны, увеличить их значения в 2 раза; во всех отальных случаях отрицательные числа заменить их модулями, а положительные оставить без изменения. (Надо написать программу на паскале)
Ответы (1)
Даны 2 действительных числа. Заменить первое число нулем, если оно меньше или равно второго, и оставить числа без изменения числа в противном случае. Числа вводятся пользователем с клавиатуры. Результат работы программы выводится на экран
Ответы (1)