Задать вопрос
1 декабря, 06:57

Задано число, проверить,

если число положительное то его нужно удвоить, если число отрицательное

уменьшить в 2 раза, иначе оставить без изменения.

+4
Ответы (2)
  1. 1 декабря, 07:49
    0
    Var x: real;

    begin

    readln (x) ;

    if x>0 then x*=2 else if x<0 then x/=2;

    writeln (x) ;

    end.
  2. 1 декабря, 08:59
    0
    Var x: real;

    begin

    readln (x) ;

    if x>=0 then x: = writeln (x*2) else x: = writeln (x/2) ;

    end.

    Второй вариант:

    var x: real;

    begin

    readln (x) ;

    if x>=0 then x:=x*2 else x: = x/2;

    writeln (x)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задано число, проверить, если число положительное то его нужно удвоить, если число отрицательное уменьшить в 2 раза, иначе оставить без ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Помогите написать в Pascal. Даны два числа, если второе число отрицательное, необходимо уменьшить первое число в 5 раз, иначе числа оставить без изменения
Ответы (1)
Pascal. Даны 2 числа, если первое больше второго по модулю или 2-е число отрицательное, необходимо уменьшить первое число в 5 раз, иначе числа оставить без изменения.
Ответы (2)
Составить программу, которая запрашивает целое число, не равное нулю, сообщает, положительное оно или отрицательное. и при этом положительное число уменьшает в 2 раза, а отрицательное возводит в квадрат.
Ответы (1)
Напишите программу вывода на экран фразы "Число положительное", если введенное число положительное, и "Число отрицательное", если введенное число отрицательное.
Ответы (1)