Задать вопрос
18 февраля, 16:17

Даны действительные числа x, y, z Если все числа положительны, увеличить их значения в 2 раза; во всех отальных случаях отрицательные числа заменить их модулями, а положительные оставить без изменения. (Надо написать программу на паскале)

+2
Ответы (1)
  1. 18 февраля, 17:49
    0
    Var x, y, z:integer;

    begin

    write ('введите X: ') ;

    readln (x) ;

    write ('введите Y: ') ;

    readln (y) ;

    write ('введите Z: ') ;

    readln (z) ;

    if (x>0) and (y>0) and (z>0) then

    begin x:=x+2; y:=y+2; z:=z+2; end

    else begin x:=abs (x) ; y:=abs (y) ; z:=abs (z) ; end;

    writeln ('x = ', x) ;

    writeln ('y = ', y) ;

    writeln ('z = ', z) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны действительные числа x, y, z Если все числа положительны, увеличить их значения в 2 раза; во всех отальных случаях отрицательные числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу в Паскале по условию Даны действительные числа x, y. Если х, у отрицательны, то каждое значение заменить его модулем; если отрицательное только одно из них, то оба значения увеличить на 27;
Ответы (1)
1) Вывести на экран кол-во и чётные числа (в строку на отрезке) от 23 до 40. 2) Заменить отрицательные числа их модулями положительные на отрицательные на отрезке от - 8 до 6.
Ответы (1)
Даны действительные числа x, y. Если x и y отрицательны, то каждое значение заменить модулем; если отрицательно только одно из них, то оба значения увеличить на 0,5; если оба значения неотрицательны и ни одно из них не пренадлежит отрезку [0.
Ответы (1)
Составить программу в паскале, в которой: а) неотрицательные числа заменить sqr, а отрицательные заменить числом 12345. б) Подсчитать и вывести отрицательные элементы массива
Ответы (1)
С клавиатуры вводятся действительные числа x и y. Если x и y положительные, то каждое число удвоить; если оба значения принадлежит отрезку [-9; - 3], то оба значения увеличить в десять раз; в остальных случаях найти произведение
Ответы (1)