Задать вопрос
14 ноября, 23:08

Дан массив из n элементов. все элементы масивы расположить в обратном порядке

+4
Ответы (1)
  1. 15 ноября, 02:05
    0
    Const

    n=15;

    var

    a:array[1 ... n] of integer;

    i, t:integer;

    begin

    Randomize;

    Writeln ('Исходный массив') ;

    for i:=1 to n do begin

    a[i]:=Random (50) + 10;

    Write (a[i]:3)

    end;

    Writeln;

    for i:=1 to n div 2 do

    begin t:=a[i]; a[i]:=a[n-i+1]; a[n-i+1]:=t end;

    Writeln ('Результирующий массив') ;

    for i:=1 to n do Write (a[i]:3) ;

    Writeln;

    end.

    Пример

    Исходный массив

    25 19 47 34 22 54 52 11 40 13 25 47 29 50 58

    Результирующий массив

    58 50 29 47 25 13 40 11 52 54 22 34 47 19 25
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из n элементов. все элементы масивы расположить в обратном порядке ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)