Задать вопрос
7 ноября, 21:54

Решить тест

Дан алгоритм Евклида.

begin

repeat

r:=a mod b; a:=b; b:=r

until b=0;

qcd:=a

end; Сколько операций сравнения будет выполнено в этом алгоритме, если a=500, b=13?

1) 1;

2) 2;

3) 3;

4) 4.

+5
Ответы (1)
  1. 8 ноября, 00:40
    0
    1) 500 : 13 (остаток r=6)

    2) 13 : 6 (остаток 7)

    3) 7 : 6 (остаток 1)

    4) 6 : 1 (остаток 0)

    ответ 4) 4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить тест Дан алгоритм Евклида. begin repeat r:=a mod b; a:=b; b:=r until b=0; qcd:=a end; Сколько операций сравнения будет выполнено в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Цикл с параметром и шагом - 1 объявляется с использованием конструкции a) for i:=i1 downto i2 do begin ... end; b) repeat begin ... end until (выражение_условие) ; c) for i:=i1 to i2 do begin ... end; d) if (выражение_условие) begin ...
Ответы (1)
Uses crt; var n, s, s1, s2, k:integer; begin writeln ('Введите число: ') ; readln (n) ; s:=0; s1:=0; s2:=0; while n>0 do begin inc (k) ; if k mod 2 = 0 then begin s:=s+n mod 10; n:=n div 10; end else begin s1:=s1+n mod 10; n:=n div 10; end;
Ответы (1)
Определить значение выражения: 1) 10 div 15 2) 10 div 2 3) 10 mod 2 4) 10 mod 17 5) 123 mod 10 6) 123 div 10 7) 1 div 2 8) 123 mod 1000 9) 100 mod 27 div 3 10) 100 div 5 mod 3 11) 98725 div 1000 mod 10 12) 100 mod 5 div 3
Ответы (1)
1) Сколько раз выполниться цикл: a) For i:=7 downto - 3 do k:=k+1; b) k:=0; while k < 15 do begin k:=k+4; end; c) k:=10; repeat k:=k-1; until k>2; 2) Определите, что будет напечатано в результате работы следующего фрагмента программы: a) s:=0;
Ответы (1)
Укажите наибольшее х, при вводе которого алгоритм печатает сначала 3, а потом 4. Var x, L, M: integer; begin readln (x) ; L:=0; M:=0; while x>0 do begin L:=L+1 If M< (x mod 5) then Begin M:=x mod 5 End X:=x div 5; End. Writeln (L) ; write (M) ; End
Ответы (1)