Задать вопрос
5 января, 06:31

Составить программу на языке Паскаль.

Спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал дневную норму на 10% от нормы предыдущего дня. Через сколько дней спортсмен будет пробегать более 20 км в день?

+5
Ответы (1)
  1. 5 января, 07:58
    0
    Var s:real; n:integer;

    begin

    s:=10;

    n:=1;

    while s<20 do

    begin

    s:=s*1.1;

    n:=n+1;

    end;

    writeln (' n = ', n) ;

    end.

    Результат:

    n = 9
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на языке Паскаль. Спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал дневную норму на 10% от ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Turbo Pascal. Спортсмен пробежал 10 км в первый день. Каждый следующий день он увеличивал норму на 10% от нормы предыдущего дня. Определить: a) Через сколько дней он будет пробегать не более 20 км? б) Сколько километров он пробежит на 7-ой день?
Ответы (1)
Составит блок - схему и программу начав тренировки спортсмен пробежал 10 км, каждый следующий день увеличивал дневную норму на 10% от нормы предыдущего дня. Какую сумарную путь пробежал за 7 дней?
Ответы (1)
Спортсмен в первый день пробежал 8 км. Каждый следующий день он увеличивал дневную норму на 10% от нормы предыдущего дня. Определить, через сколько дней спортсмен пробежит суммарный путь 40 км. Задача в Pascal
Ответы (2)
Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за 7 дней? Составить программу в паскале помощью цикла repeat.
Ответы (2)
Начав тренировки, спортсмен пробежал в первый день 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Сколько он пробегал за каждый день тренировки? Какой суммарный путь пробежит спортсмен за 7 дней?
Ответы (1)