Задать вопрос
11 июля, 15:01

Спортсмен в первый день пробежал 8 км. Каждый следующий день он увеличивал дневную норму на 10% от нормы предыдущего дня. Определить, через сколько дней спортсмен пробежит суммарный путь 40 км. Задача в Pascal

+1
Ответы (2)
  1. 11 июля, 16:33
    0
    Var a, s: real;

    i: integer;

    begin

    a:=8;

    s:=a;

    i:=1;

    repeat

    i:=i+1;

    a:=a*1.1;

    s:=s+a;

    until s>=40;

    writeln (i) ;

    / / через геометрическую прогрессию

    / / s:=ln (1.5) / ln (1.1) ;

    / / if frac (s) >0 then s:=int (s) + 1;

    / / writeln (s) ;

    end.
  2. 11 июля, 18:03
    0
    Var

    S, a:real;

    k:integer;

    Begin

    a:=8;

    k:=0;

    Repeat

    k:=k+1;

    S:=S+a;

    a:=a*1.1;

    Until S>=40;

    WriteLn ('k = ', k)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Спортсмен в первый день пробежал 8 км. Каждый следующий день он увеличивал дневную норму на 10% от нормы предыдущего дня. Определить, через ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Начав тренировки, спортсмен пробежал в первый день 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Сколько он пробегал за каждый день тренировки? Какой суммарный путь пробежит спортсмен за 7 дней?
Ответы (1)
Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за 7 дней? Составить программу в паскале помощью цикла repeat.
Ответы (2)
Нужно в паскале ABS Начав тренировки спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за 7 дней?
Ответы (1)
Начав тренировки спортсмен в первый день пробежал 10 км. Каждый следущий день он увеличивал дневную норму на 8% от нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за n дней?
Ответы (1)
начав тренировки, спортсмен в 1 день пробежал 10 км. каждый день он увеличивал дневную норму бега на 10% нормы предыдущего дня. какой суммарный путь пробежит спортсмен за 7 дней?
Ответы (2)