Задать вопрос
2 июля, 09:02

Ввести с клавиатуры 10 произвольных чисел, вычислить сумму чётных среди них.

(тема: накопление суммы)

+3
Ответы (1)
  1. 2 июля, 09:28
    0
    Var a, b, sum:integer;

    begin

    sum:=0;

    for a:=0 to 9 do begin

    read (b) ;

    if (b mod 2 = 0) then sum:=sum+b;

    end;

    writeln ('сумма чётных чисел sum=', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести с клавиатуры 10 произвольных чисел, вычислить сумму чётных среди них. (тема: накопление суммы) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Ввести с клавиатуры длину и ширину прямоугольной двери. Кроме того, ввести длину, ширину и высоту шкафа - прямоугольного параллелепипеда. Выяснить, можно ли пронести шкаф через дверь, не разбирая его. 2. Ввести три вещественных числа с клавиатуры.
Ответы (1)
Помогите написать программу в Паскале. Ввести с клавиатуры 6 произвольных чисел. Вычислить среднее арифметическое тех чисел, которые делятся на 4 и заканчиваются на 5. (Остаток на деление на 10 равен 5).
Ответы (1)
С клавиатуры вводятся 3 числа. Найти количество и сумму четных чисел среди них. Если среди введенных четных нет, то вывести соответствующее сообщение.
Ответы (1)
Помогите решить задачу на паскале. Дан массив B (n*m). Элементы массива ввести с клавиатуры. Найти сумму элементов, которые больше данного числа A, но меньше данного числа С. Числа A и С ввести с клавиатуры
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)