Задать вопрос
12 июня, 20:02

Ребяят, нужно найти сумму цифр трехзначного числа и записать в паскале

+3
Ответы (2)
  1. 12 июня, 20:50
    0
    var a, a12, a1, a2, a3, s: integer;

    begin

    readln (a) ;

    a1:=a div 100;

    a12:=a mod 100;

    a2:=a12 div 10;

    a3:=a12 mod 10;

    s:=a1+a2+a3;

    writeln (s) ;

    end.

    a1-первое число трехзначного числа, a2-второе, a3-третье, a12-вторые два числа
  2. 12 июня, 23:31
    0
    var

    a, s: integer; / / целочисленный тип данных

    begin

    writeln ('Введите число:') ;

    readln (a) ; / / вводим число (можно больше трех знаков)

    while a 0 do / / пока остались цифры в числе выполнять ...

    begin

    s : = s + (a mod 10) ; / / Отбираем последнюю цифру числа и прибавляем к сумме

    a : = a div 10; / / Стираем последнюю цифру числа

    end;

    writeln ('Сумма цифр = ', s) / / выводим результат

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ребяят, нужно найти сумму цифр трехзначного числа и записать в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Ребяят, нужно найти сумму цифр четырехзначного числа и записать в паскале
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)