Задать вопрос
13 сентября, 03:58

Ребяят, нужно найти сумму цифр четырехзначного числа и записать в паскале

+2
Ответы (1)
  1. 13 сентября, 05:41
    0
    Begin

    var s:=readstring () ;

    if s. Length=4 then

    write (strtoint (s[1]) + strtoint (s[2]) + strtoint (s[3]) + strtoint (s[4])) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ребяят, нужно найти сумму цифр четырехзначного числа и записать в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Ребяят, нужно найти сумму цифр трехзначного числа и записать в паскале
Ответы (2)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)
Записать в Паскале. Найти произведение всех цифр заданного четырехзначного числа.
Ответы (1)