Задать вопрос
6 августа, 00:32

Записать в Паскале. Найти произведение всех цифр заданного четырехзначного числа.

+4
Ответы (1)
  1. 6 августа, 03:58
    0
    Var

    n, p: integer;

    begin

    Write ('Введите натуральное четырехзначное число - > ') ;

    Readln (n) ;

    p : = (n div 1000) * (n mod 10) ; { произведение первой и последней цифр }

    n : = (n mod 1000) div 10; { вторая и третья цифры }

    p : = p * (n div 10) * (n mod 10) ;

    Writeln ('Произведение цифр числа равно ', p)

    end.

    Тестовое решение:

    Введите натуральное четырехзначное число - > 2437

    Произведение цифр числа равно 168
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Записать в Паскале. Найти произведение всех цифр заданного четырехзначного числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В Паскале. Найти произведение всех цифр заданного четырехзначного числа.
Ответы (1)
Автомат получает на вход четырехзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам: 1) вычисляются два числа - сумма "кратчайших" цифр четырехзначного числа, а также сумма "средних" цифр заданного
Ответы (1)
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)