Задать вопрос
13 сентября, 03:56

В Паскале. Найти произведение всех цифр заданного четырехзначного числа.

+4
Ответы (1)
  1. 13 сентября, 04:12
    0
    Var

    n, ed, des, sot, tis:integer;

    S:real;

    Begin

    Readln (n) ;

    ed:=n mod 10;

    des:=n div 10 mod 10;

    sot:=n div 100 mod 10;

    tis:=n div 1000 mod 10;

    S:=ed*des*sot*tis;

    Writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В Паскале. Найти произведение всех цифр заданного четырехзначного числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Записать в Паскале. Найти произведение всех цифр заданного четырехзначного числа.
Ответы (1)
Автомат получает на вход четырехзначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам: 1) вычисляются два числа - сумма "кратчайших" цифр четырехзначного числа, а также сумма "средних" цифр заданного
Ответы (1)
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)