Задать вопрос
12 июня, 21:41

Даны вещественные числа x, y, z. Вычислите следующее выражение:max (x+y+z, xyz) ;

+3
Ответы (1)
  1. 12 июня, 22:31
    0
    Function z00006 (x, y, z : real) : real;

    var

    m1, m2 : real;

    begin

    {Äàíû âåùåñòâåííûå : èñëà x, y, z. Âû:èñëèòå ñëåäóþùåå

    âûðàæåíèå: max (x+y+z, xyz) }

    m1 : = x + y + z;

    m2 : = x * y * z;

    if (m1 > m2) then

    begin

    z00006 : = m1;

    end

    else

    begin

    z00006 : = m2;

    end;

    end;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны вещественные числа x, y, z. Вычислите следующее выражение:max (x+y+z, xyz) ; ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Где ошибка? Sub сер Dim x, y, z, f, max, min As Single x = Val (InputBox (2)) y = (InputBox (6)) z = (InputBox (10)) If x / 2 > y / 3 > z / 4 Then If x / 2 > y / 3 Then max = x / 2 Else max = y / 3 End If End If Else If y / 3 > z / 4 Then max =
Ответы (1)
Паскаль Как написать программу, которая уменьшала бы ВСЕ максимальные элементы в два раза? Так? max:=a[1,1]; if a[i, j] > max then max: = a[i, j]; end; max: = max div 2;
Ответы (2)
1) Преобразуйте следующее двоичное число в восьмеричное: 10011 2) Преобразуйте следующее двоичное число в десятеричное: 101100 3) Преобразуйте следующее двоичное число в шестнадцатеричное: 1011000111 4) Преобразуйте следующее восьмеричное число в
Ответы (1)
Исправить ошибки в паскале program massiv2; type mas=array [1 ... 100] of integer; var a: = Max; i, n, min, max, b : integer; недопустимый символ: = (д/б просто :; неизвесмтное имя типа max) begin writeln ('n=') ; readln (n) ;
Ответы (2)
Составить блок-схему к данному коду Var Min, Max, i, m, n:Integer Begin Readln (n) ; max:=-maxint-1; min:=maxint For I:=1 to n do begin ReadLn (m) ; If (m>max) then max:=m; If (m end; Writeln (max,' ', min) ; End.
Ответы (1)