Задать вопрос
24 января, 13:48

Написать программу калькулятор: задаются два числа, символ арифметической операции (+,-,*,/), вывести результат в виде (5+6=11)

+1
Ответы (2)
  1. 24 января, 14:18
    0
    Program calculator;

    var a, b:real; x:char;

    begin

    write ('Введите два числа') ;

    readln (a, b) ;

    write ('Выберите действие') ;

    readln (x) ;

    If x='+' then writeln (a, x, b,'=', a+b) ;

    If x='-' then writeln (a, x, b,'=', a-b) ;

    If x='*' then writeln (a, x, b,'=', a*b) ;

    If x='/' then writeln (a, x, b,'=', a/b) ;

    end.
  2. 24 января, 14:48
    0
    uses crt;

    var a, b, s:real; z:char;

    begin

    write ('Vvedite A = ') ;

    readln (a) ;

    write (' + - / * : ') ;

    readln (z) ;

    write ('Vvedite B = ') ;

    readln (b) ;

    case z of

    '+': begin s:=a+b; writeln (a,' + ', b,' = ', s) ; end;

    '-': begin s:=a-b; writeln (a,' - ', b,' = ', s) ; end;

    '*': begin s:=a*b; writeln (a,' * ', b,' = ', s) ; end;

    '/': begin s:=a/b; writeln (a,' / ', b,' = ', s) ; end;

    else

    writeln ('error: incorrect operation symbol!') ;

    end;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу калькулятор: задаются два числа, символ арифметической операции (+,-,*,/), вывести результат в виде (5+6=11) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу калькулятор: задаются два числа, символ арифметической операций (+,-,*,/), вывести результат в виде (5 + 6=11)
Ответы (1)
Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию.
Ответы (1)
Информатика. Составить программу "Электронный калькулятор". Программа должна предложить ввести два действительных числа и знак арифметической операции (+,-,*,/). Произвести требуемое вычисление и вывести результат операции.
Ответы (1)
Укажите алгоритмы устранения следующих ошибок: 1) Установить курсор на место вставки. 2) Нажать клавишу с нужным символом. Что это Лишний символ, пропущенный символ, неверный символ? 1) Установить курсор за ошибочным символом.
Ответы (1)
Ввести с клавиатуры знак арифметической операции (либо + либо - либо * либо / (деление) и. два числа. Вывести на экран результат. При вводе знака операции # выход из программы. 6
Ответы (1)