Задать вопрос
19 сентября, 09:38

Ввести с клавиатуры знак арифметической операции (либо + либо - либо * либо / (деление) и. два числа. Вывести на экран результат. При вводе знака операции # выход из программы. 6

+4
Ответы (1)
  1. 19 сентября, 12:31
    0
    uses crt;

    var a, b, s:real; z:char;

    begin

    write ('Vvedite A = ') ;

    readln (a) ;

    write (' + - / * : ') ;

    readln (z) ;

    write ('Vvedite B = ') ;

    readln (b) ;

    case z of

    '+': begin s:=a+b; writeln (a,' + ', b,' = ', s) ; end;

    '-': begin s:=a-b; writeln (a,' - ', b,' = ', s) ; end;

    '*': begin s:=a*b; writeln (a,' * ', b,' = ', s) ; end;

    '/': begin s:=a/b; writeln (a,' / ', b,' = ', s) ; end;

    else

    writeln ('error: incorrect operation symbol!') ;

    end;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести с клавиатуры знак арифметической операции (либо + либо - либо * либо / (деление) и. два числа. Вывести на экран результат. При вводе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию.
Ответы (1)
1) ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
Ввести с клавиатуры 2 числа a и b. Если a = b; вывести на экран "a = b". Если a > b; вывести на экран "a > b". Если a < b; вывести на экран "a < b".
Ответы (1)
10. Составить программу, осуществляющую ввод числовых переменных. При вводе положительного числа вывести информацию: "Число больше ноля", при вводе отрицательного числа - "Число меньше ноля", при вводе ноля - "Вы ввели ноль".
Ответы (1)