Задать вопрос
11 февраля, 22:20

Написать программу калькулятор: задаются два числа, символ арифметической операций (+,-,*,/), вывести результат в виде (5 + 6=11)

+4
Ответы (1)
  1. 12 февраля, 00:52
    0
    Program calculator;

    var a, b:real; x:char;

    begin

    write ('Введите два числа') ;

    readln (a, b) ;

    write ('Выберите действие') ;

    readln (x) ;

    If x='+' then writeln (a, x, b,'=', a+b) ;

    If x='-' then writeln (a, x, b,'=', a-b) ;

    If x='*' then writeln (a, x, b,'=', a*b) ;

    If x='/' then writeln (a, x, b,'=', a/b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу калькулятор: задаются два числа, символ арифметической операций (+,-,*,/), вывести результат в виде (5 + 6=11) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу калькулятор: задаются два числа, символ арифметической операции (+,-,*,/), вывести результат в виде (5+6=11)
Ответы (2)
Укажите алгоритмы устранения следующих ошибок: 1) Установить курсор на место вставки. 2) Нажать клавишу с нужным символом. Что это Лишний символ, пропущенный символ, неверный символ? 1) Установить курсор за ошибочным символом.
Ответы (1)
Составить программу - калькулятор, которая запрашивает тип арифметической операции: 1-сложение, 2-вычитание, 3 - умножение, 4 - деление, а также два числа и производит над ними соответствующую арифметическую операцию.
Ответы (1)
Информатика. Составить программу "Электронный калькулятор". Программа должна предложить ввести два действительных числа и знак арифметической операции (+,-,*,/). Произвести требуемое вычисление и вывести результат операции.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)