Задать вопрос
10 февраля, 03:11

Составить на языке Паскаль программу, которая запрашивает с клавиатуры N целых чисел и считает, сколько из них положительных, сколько отрицательных и сколько нулей. Разработать для программы не менее двух тестов и доказать правильность её работы.

+4
Ответы (2)
  1. 10 февраля, 04:38
    0
    const N = 4;

    var

    a: array[1 ... 4] of integer;

    i, c, c2, c3: integer;

    begin

    for i : = 1 to n do begin

    readln (a[i]) ;

    if (a[i] = 0) then inc (c)

    else if (a[i] < 0) then inc (c2)

    else inc (c3) ;

    end;

    writeln ('Нулевых эл.: ', c) ;

    writeln ('Отрицательных эл.: ', c2) ;

    writeln ('Положительных эл.: ', c3) ;

    end.
  2. 10 февраля, 06:59
    0
    var

    number, N, npol, notr, n0, i: integer; {npol - количество положительных чисел, notr - количество отрицательных, n0 - количество нулей}

    begin

    writeln ('Введите N') ;

    readln (N) ;

    for i: = 1 to N do

    begin

    writeln ('Введите целое число') ;

    readln (number) ;

    if number < 0 then notr: = notr + 1;

    if number > 0 then npol: = npol + 1;

    if number = 0 then n0: = n0 + 1;

    end;

    writeln ('Было введено ', notr, ' отрицательных чисел, ', npol, ' положительных чисел, ', n0, ' нулей') ;

    end.

    А для тестов ты просто вводишь числа и проверяешь, правильно ли нашлось количество.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить на языке Паскаль программу, которая запрашивает с клавиатуры N целых чисел и считает, сколько из них положительных, сколько ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Где ошибка? Задание: Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных целых чисел и ищет их сумму. Число N вводится с клавиатуры.
Ответы (1)
Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.
Ответы (1)
2. Разработать программу, которая запрашивает ввод целого числа в переменную Z, определяет и выводит на экран сообщение, какое это число - положительное, отрицательное или равное 0.
Ответы (1)
1. с клавиатуры вводится n действительных чисел. Определить сколько в данной последовательности нечетных отрицательных чисел. 2. Составить программу на языке Паскаль вычисления кубов чисел вводимых с клавиатуры. 3.
Ответы (1)