Задать вопрос
14 августа, 10:05

Вычислить среднее арифметическое значение тех элементов одновременного массива, которые попадают в интервал от - 2 до 10. Размерность массива произвольная. ИЛИ Дан массив, содержащий 12 элементов и заполненный по формуле A = (i-4) / (3*i). Найти количество элементов в этом массиве больших 0, но меньших 0,2. (решение писать как в турбо паскале)

+3
Ответы (1)
  1. 14 августа, 12:02
    0
    const

    n=10;

    var

    a:array [1 ... n] of integer;

    i, s, k:integer;

    sr:real;

    begin

    randomize;

    s:=0;

    k:=0;

    for i:=1 to n do begin

    a[i]:=random (31) - 10;

    write (a[i],' ') ;

    if (a[i]>-2) and (a[i]<10) then

    begin

    k:=k+1;

    s:=s+a[i];

    end;

    end;

    writeln;

    sr:=s/k;

    writeln (sr:0:2) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить среднее арифметическое значение тех элементов одновременного массива, которые попадают в интервал от - 2 до 10. Размерность ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Вычислить среднее арифметическое тех элементов массива, значения которых попадают в интервал от - 2 до 10. Размерность массива произвольная.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)