Задать вопрос
9 сентября, 18:23

Вычислить среднее арифметическое тех элементов массива, значения которых попадают в интервал от - 2 до 10. Размерность массива произвольная.

+5
Ответы (1)
  1. 9 сентября, 20:52
    0
    Var

    i, s, t, n:integer;

    a:array[1 ... 100] of integer;

    begin

    write ('Write size array: ') ; readln (n) ;

    for i:=1 to n do

    begin

    a[i]:=Random (150) - 50;

    write (a[i]:4) ;

    end;

    s:=0;

    t:=0;

    for i:=1 to n do

    if (a[i]>=-2) and (a[i]<=10)

    then begin s:=s+a[i]; inc (t) ; end;

    writeln ('Average: ', s/t:0:2) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить среднее арифметическое тех элементов массива, значения которых попадают в интервал от - 2 до 10. Размерность массива произвольная. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить среднее арифметическое значение тех элементов одновременного массива, которые попадают в интервал от - 2 до 10. Размерность массива произвольная. ИЛИ Дан массив, содержащий 12 элементов и заполненный по формуле A = (i-4) / (3*i).
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите с информатикой 1. Что такое массив? 2. Что такое элемент массива? 3. Что такое индекс массива? 4. Что такое размерность массива? 5. Зачем нужны массивы? 6. Как можно обратиться к ячейке массива? 7. Какого типа могут быль элементы массива? 8.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)