Задать вопрос
29 августа, 14:36

1. Написать и отладить программу заполнения массива из 10 элементов случайными числами от - 5 до 5. Удалить элемент с номером 4. Распечатать массив до удаления элемента и после.

+1
Ответы (1)
  1. 29 августа, 15:58
    0
    var

    a:array [1 ... 10] of integer;

    i:integer;

    begin

    Randomize;

    for i: = 1 to 10 do a[i]:=random (10) - 5;

    for i: = 1 to 10 do write (a[i],' ') ;

    writeln;

    for i: = 4 to 9 do a[i]:=a[i+1];

    for i: = 1 to 9 do write (a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Написать и отладить программу заполнения массива из 10 элементов случайными числами от - 5 до 5. Удалить элемент с номером 4. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите с заданиями по информатике 9 класс. 1) составьте программу заполнения массива а 1 ... 10 случайными целыми числами в диапозоне от N до M.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)