Задать вопрос
29 августа, 11:38

Дана числовая последовательность. Найти сумму положительных элементов, количество нулей и сумму отрицательных элементов. Вывести найденные количества и суммы (если они не были сформированы вывести соответсвующее сообщение).

+4
Ответы (1)
  1. 29 августа, 11:52
    0
    Var

    a, s, s2:real;

    k, n, i:integer;

    begin

    readln (n) ;

    for i:=1 to n do

    begin

    readln (a) ;

    if a=0 then

    k:=k+1;

    if a>0 then

    s:=s+a;

    if a<0 then

    s2:=s2+a;

    end;

    if k=0 then

    writeln ('Нет 0')

    else

    writeln ('k = ', k) ;

    if s=0 then

    writeln ('Нет полож')

    else

    writeln ('S = ', s) ;

    if s2=0 then

    writeln ('Нет отриц')

    else

    writeln ('S <0 = ', s2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана числовая последовательность. Найти сумму положительных элементов, количество нулей и сумму отрицательных элементов. Вывести найденные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
N первых простых чисел представляются в двоичной системе счисления и записываются подряд. Из полученной последовательности нулей и единиц формируется числовая последовательность, каждый элемент которой представляет количество нулей, идущих подряд.
Ответы (1)
10. В учебнике по математике одновременно хранится информация: а) исключительно числовая информацию. б) графическая, звуковая и числовая; в) графическая, текстовая и звуковая; г) только текстовая информацию; д) текстовая, графическая, числовая
Ответы (1)