Задать вопрос
29 августа, 18:28

Составьте алгоритм и реализуйте его в виде программы подсчитывающей количество символов введённых с клавиатуры и затем выводящей эту последовательность символов в обратном порядке

+5
Ответы (1)
  1. 29 августа, 19:48
    0
    Допустим символы вводятся до символа "." - точка.

    Точку в количество включать не будем

    var

    i, j: integer;

    s: array[1 ... 255] of char;

    begin

    while s[i]'.' do

    begin

    read (s[i]) ;

    inc (i) ;

    end;

    writeln (i) ;

    for j:=i downto 1 do

    write (s[j]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте алгоритм и реализуйте его в виде программы подсчитывающей количество символов введённых с клавиатуры и затем выводящей эту ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Составьте программу, которая: а) Определяет коды двух введённых с клавиатуры символов; б) Выполняет операцию сцепления трёх введённых с клавиатуры символов; на Pascal
Ответы (1)
Какие программы относятся к прикладным программам? A. Программы общего назначения. B. Специальные профессиональные программы. C. Языки программирования. D. Сервисные программы. E. Операционные системы.
Ответы (1)
укажите истинное высказывание (отметьте точкой) алгоритм всегда представляет собой некоторую последовательность вычислений алгоритм может представлять собой некоторую последовательность вычислений, а может последовательность действий
Ответы (1)
Антивирусные программы-это 1. программы сканирования и распознавания 2. программы выявляющие и лечащие компьютерные вирусы 3. программы только выявляющие вирусы 4. программы-архиваторы разархиваторы
Ответы (1)