Задать вопрос
15 июля, 09:30

Паскаль

Найти произведение четных натуральных чисел, меньших 100

+5
Ответы (2)
  1. 15 июля, 09:47
    0
    var x, y:integer;

    Begin

    x:=2;

    y:=1;

    while x100 do

    Begin

    y:=y*x;

    x:=x+2;

    end;

    write (y) ;

    End.

    Числа меньше ста, все правильно. Не понял причину, почему модератор отправил на доработку.
  2. 15 июля, 11:52
    0
    var i, s:integer;

    Begin

    s:=1;

    for i : = 1 to 99 do

    if i mod 2 = 0 then s:=s*i;

    writeln (s) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль Найти произведение четных натуральных чисел, меньших 100 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
1) найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2) вывести на экран натуральные нечетные числа от 5 до 55. тоже паскаль 3) найти произведение последовательных натуральных чисел от n до m.
Ответы (1)
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)
Написать программу на языке паскаль. С клавиатуры вводятся несколько натуральных целых чисел. Необходимо чтобы вычислялось сколько введено чисел, сколько из них четных и общая сумма этих чисел.
Ответы (1)