Задать вопрос
13 апреля, 22:49

Напишите программу на языке паскаль, которая вычесляет сумму:

а) первых n натуральных чисел;

б) квадратов первых n натуральных чисел;

в) всех чётных чисел в диапазоне от 1 до n;

г) всех двузначных чисел.

+4
Ответы (1)
  1. 14 апреля, 02:29
    0
    Var

    i, s1, s2, s3, s4, n: integer;

    begin

    write ('n = ') ;

    readln (n) ;

    s1 : = 0;

    s2 : = 0;

    s3 : = 0;

    s4 : = 0;

    for i : = 1 to n do

    begin

    s1 : = s1 + i;

    s2 : = s2 + sqr (i) ;

    if i mod 2 = 0 then s3 : = s3 + i;

    end;

    for i : = 10 to 99 do s4 : = s4 + i;

    writeln ('Сумма первых n натуральных чисел: ', s1) ;

    writeln ('Сумма квадратов первых n натуральных чисел: ', s2) ;

    writeln ('Сумма всех четных чисел: ', s3) ;

    writeln ('Сумма всех двухзначных чисел: ', s4) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Написать программу которая минимальное значение четных и не четных в заданном диапазоне и сумму и среднее ариф. Всех и четных и нечетных. python3 через цикл while
Ответы (1)
1. Написать программу для определения количества двузначных чисел в диапазоне от А до B, которые при делении на 6 дают остаток 2. 2. Найти сумму двузначных чисел в диапазоне от А до B, в которых первая цифра ровно в 2 раза больше второй.
Ответы (1)
Программа на с++ Напишите программу, которая вводит натуральные числа a и b, и выводит сумму квадратов натуральных чисел в диапазоне от a до b. Входные данные Входная строк содержит два натуральных числа - границы диапазона a и b.
Ответы (1)