Задать вопрос
13 апреля, 23:17

Составить алгоритм и программу, определяющую последнюю цифру числа a (в n степени), где натуральные числа n, а вводятся.

Ответ на паскале

+2
Ответы (1)
  1. 14 апреля, 01:38
    0
    Обратим внимание, что при возведении натурального числа a в натуральную степень n последняя цифра результата определяется, как значение последней цифры d числа a, возведенного в степень n

    Поскольку операция возведения в степень n сводится к умножению n раз числа самого на себя, то получая при очередном умножении многоразрядное число, мы можем снова принимать в расчет только его младшую цифру.

    Это позволяет построить цикл на n умножений, каждый раз получая младшую цифру при помощи операции mod.

    var

    a:longint;

    n, d, i, p:integer;

    begin

    Write ('Введите натуральное число a: ') ; Read (a) ;

    Write ('Введите натуральную степень n: ') ; Read (n) ;

    a:=a mod 10; p:=a;

    for i:=2 to n do

    begin a:=a*p; a:=a mod 10 end;

    Writeln ('Последняя цифра равна ', a)

    end.

    Тестовое решение:

    Введите натуральное число a: 154

    Введите натуральную степень n: 9

    Последняя цифра равна 4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить алгоритм и программу, определяющую последнюю цифру числа a (в n степени), где натуральные числа n, а вводятся. Ответ на паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
Составить программу, определяющую, является ли данное утверждение истинным: Двузначное число А начинается на 3 Составить программу, определяющую, является ли данное утверждение истинным: Ровно одно из чисел А и В не превышает 100
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Из трехзначного числа x вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа x, то получилось 237. Найти число x. Решить на Паскале
Ответы (1)