Задать вопрос
15 июля, 09:08

Дан одномерный массив z элементов. Найти сумму отрицательных и положительных элементов массива

+5
Ответы (1)
  1. 15 июля, 09:50
    0
    Const

    K = 10;

    Var

    Z:array[1 ... K] of integer;

    i:integer;

    P, O:real;

    Begin

    For i: = 1 to K do

    Begin

    Z[i]:=random (21) - 10;

    Write (Z[i],' ') ;

    if Z[i]<0 then O:=O+Z[i]

    else P:=P+Z[i];

    End;

    WriteLn;

    WriteLn ('Сумма положительных элементов: ', P) ;

    WriteLn ('Сумма отрицательных элементов: ', O) ;

    End.

    То же, но с вводом с клавы:

    Const

    K = 10;

    Var

    Z:array[1 ... K] of integer;

    i:integer;

    P, O:real;

    Begin

    WriteLn ('Введите элементы массива:') ;

    For i: = 1 to K do

    Begin

    Read (Z[i]) ;

    if Z[i]<0 then O:=O+Z[i]

    else P:=P+Z[i];

    End;

    WriteLn;

    WriteLn ('Сумма положительных элементов: ', P) ;

    WriteLn ('Сумма отрицательных элементов: ', O) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан одномерный массив z элементов. Найти сумму отрицательных и положительных элементов массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)