Задать вопрос
26 марта, 11:03

Написать программу на языке паскаль. С клавиатуры вводятся несколько натуральных целых чисел. Необходимо чтобы вычислялось сколько введено чисел, сколько из них четных и общая сумма этих чисел. Например: вводим числа 3425 - получает количество чисел - 4, количество четных чисел - 2, сумма чисел - 14

+4
Ответы (1)
  1. 26 марта, 11:25
    0
    Var

    n, m, p, k, sum, x: integer;

    s: string;

    c, i: byte;

    begin

    write ('Число: ') ;

    read (n) ;

    m : = n;

    k : = 0;

    while m 0 do

    begin

    p : = m mod 10;

    K : = K + 1;

    m : = m div 10;

    end;

    Str (N, s) ;

    c : = 0;

    for i : = 1 to Length (s) do

    if s[i] in ['0', '2', '4', '6', '8'] then

    Inc (c) ;

    x : = n;

    sum : = 0;

    while (x 0) do

    begin

    sum : = sum + (x mod 10) ;

    x : = x div 10;

    end;

    writeln ('Количество чисел: ', k) ;

    writeln ('Количество четных чисел: ', c) ;

    writeln ('Cумма чисел : ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на языке паскаль. С клавиатуры вводятся несколько натуральных целых чисел. Необходимо чтобы вычислялось сколько введено ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Составить программу обмена значениями двух переменных, которые вводятся с клавиатуры. Образец: Вводим числа:a=3b=7 После обмена:b=3a=7 , через паскаль
Ответы (1)
Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.
Ответы (1)
1. Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N - количество чисел) вводятся с клавиатуры. Результаты работы программы записываются в файл Out. txt. 2.
Ответы (1)