Задать вопрос
25 декабря, 00:53

Введите с клавиатуры три числа если все числа отрицательны и не равны между собой то замените числа их квадратами и выведете результат на экран если все числа равны 0 то сделайте их соответственно равными 5, 20,15 и выведете результат. Иначе найдите и выведете сумму чисел. (в паскале)

+1
Ответы (1)
  1. 25 декабря, 02:58
    0
    Uses crt;

    var x, y, z:real;

    begin

    readln (x, y, z) ;

    if (x<0) and (y<0) and (z<0) and (xy) and (xz) and (yz) then

    write (x*x,', ', y*y,', ', z*z)

    else

    if (x=0) and (y=0) and (z=0) then write ('5, 20, 15')

    else write (x+y+z) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Введите с клавиатуры три числа если все числа отрицательны и не равны между собой то замените числа их квадратами и выведете результат на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составте программу на Паскале для решения следующей задачи. Введите с клавиатуры 3 числа: А, В и С. Если А и С кратны 5, а В не кратно, то все числа замените и квадратами и выведите результат на экран.
Ответы (1)
Составьте программу для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если А>В>C>0, то замените все числа их квадратами и выведите результаты на экран.
Ответы (1)
Введите с клавиатуры три числа x, y, z. если числа равны, то увеличте их в три раза и выведите результат на экран. Если равны только два последние числа то замените все числа на противоположные и выведите результаты.
Ответы (1)
Помогите составить программы Введите несколько чисел. Найдите произведение чисел меньших 7. Введите несколько чисел. Найдите количество двузначных чисел. Введите несколько чисел.
Ответы (1)
1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр 3.
Ответы (1)