Задать вопрос
13 мая, 15:26

Введите с клавиатуры три числа x, y, z. если числа равны, то увеличте их в три раза и выведите результат на экран. Если равны только два последние числа то замените все числа на противоположные и выведите результаты.

иначе все числа сделайте равными 222 и выведите результат

+3
Ответы (1)
  1. 13 мая, 18:15
    0
    Var

    x, y, z: integer;

    begin

    read (x, y, z) ;

    if (x = y) and (y = z) and (x = z) then

    begin

    x : = 3 * x;

    y : = 3 * y;

    z : = 3 * z;

    write (x, y, z) ;

    end

    else

    if (y = z) then

    begin

    x : = - x;

    y : = - y;

    z : = - z;

    write (x, y, z) ;

    end

    else

    begin

    x : = 222;

    y : = 222;

    z : = 222;

    write (x, y, z) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Введите с клавиатуры три числа x, y, z. если числа равны, то увеличте их в три раза и выведите результат на экран. Если равны только два ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Введите с клавиатуры два числа a и b. Если оба числа четные, то вычислите их сумки выведите результат на экран. если оба нечетные то найдите произведение этих чисел и выведите результат. Иначе, увеличить все числа в пять раз и выведите результаты.
Ответы (1)
Введите с клавиатуры три числа если все числа отрицательны и не равны между собой то замените числа их квадратами и выведете результат на экран если все числа равны 0 то сделайте их соответственно равными 5, 20,15 и выведете результат.
Ответы (1)
1. В языке PHP создайте генератор случайного числа от 1 до 10. Выведите результат выполнения на экран любым способом. 2. Если полученное случайное число четное, выведите на экран слово "четное", иначе выведите на экран слово "нечетное". 3.
Ответы (1)
Составьте программу для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если А>В>C>0, то замените все числа их квадратами и выведите результаты на экран.
Ответы (1)
Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа больше 100, то замените каждое из них меньшим и выведите результаты на экран.
Ответы (1)