Задать вопрос
18 января, 16:04

Составте программу на Паскале для решения следующей задачи. Введите с клавиатуры 3 числа: А, В и С. Если А и С кратны 5, а В не кратно, то все числа замените и квадратами и выведите результат на экран. Если только В кратно 5, то увеличьте все числа на 10 и выведите результат на экран. Иначе, найдите и выведите среднее арифметическое этих чисел.

+4
Ответы (1)
  1. 18 января, 19:58
    0
    Var

    a, b, c: integer;

    begin

    write ('Введите 3 числа: ') ;

    readln (a, b, c) ;

    if ((a mod 5) = 0) and ((c mod 5) = 0) and (b mod 5 0)

    then print (sqr (a), sqr (b), sqr (c))

    else if (b mod 5 = 0) and ((a mod 5) 0) and ((c mod 5) 0) then

    print (a+10, b+10, c+10)

    else print ((a+b+c) / 3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составте программу на Паскале для решения следующей задачи. Введите с клавиатуры 3 числа: А, В и С. Если А и С кратны 5, а В не кратно, то ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.
Ответы (1)
Составьте программу для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если А>В>C>0, то замените все числа их квадратами и выведите результаты на экран.
Ответы (1)
Введите числа А, В, С. Если А и С кратны 5, а В - не кратно, то все числа замените их квадратами. Если только В кратно 5, то увеличьте все числа на 10. Иначе, найдите их среднеарифметическое.
Ответы (1)
Введите с клавиатуры три числа: a, b, c. Если все они равны, то первое увеличьте в 10 раз, второе уменьшите в 10 раз, а третье увеличьте на 10 и выведите результаты на экран.
Ответы (1)
Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа больше 100, то замените каждое из них меньшим и выведите результаты на экран.
Ответы (1)