Задать вопрос
12 июня, 22:12

Введите с клавиатуры три числа: a, b, c. Если все они равны, то первое увеличьте в 10 раз, второе уменьшите в 10 раз, а третье увеличьте на 10 и выведите результаты на экран. Если равны только первое и последнее, то увеличьте все числа на 100 и выведите результаты. Иначе, найдите и выведите удвоенную сумму этих чисел.

+2
Ответы (1)
  1. 13 июня, 00:14
    0
    VAR a, b, c: integer;

    begin

    writeln ('Введите числа') ;

    readln (a, b, c) ;

    if (a = b) and (a = c) then begin

    writeln (a*10) ;

    writeln (b/10) ;

    writeln (a+10) ;

    end

    else if (a = c) then begin

    writeln (a+100) ;

    writeln (b+100) ;

    writeln (c+100) ;

    end

    else

    writeln (2 * (a+b+c)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Введите с клавиатуры три числа: a, b, c. Если все они равны, то первое увеличьте в 10 раз, второе уменьшите в 10 раз, а третье увеличьте на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то выведите их произведение.
Ответы (1)
Введите с клавиатуры два числа a и b. Если оба числа четные, то вычислите их сумки выведите результат на экран. если оба нечетные то найдите произведение этих чисел и выведите результат. Иначе, увеличить все числа в пять раз и выведите результаты.
Ответы (1)
Составьте блок-схемы и программы для решения следующих задач. Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. · Если разность первого и последнего, превышает второе, то выведите второе число.
Ответы (1)
Введите с клавиатуры три числа x, y, z. если числа равны, то увеличте их в три раза и выведите результат на экран. Если равны только два последние числа то замените все числа на противоположные и выведите результаты.
Ответы (1)
Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: N и M. Если оба числа больше 100, то замените каждое из них меньшим и выведите результаты на экран.
Ответы (1)