Задать вопрос
26 июня, 11:36

Найдите среднее арифметическое отрицательных чисел из n введенных.

(в паскале)

+5
Ответы (1)
  1. 26 июня, 13:03
    0
    const

    n = 3;

    var

    i, a, count, s: integer;

    begin

    for i : = 1 to n do begin

    readln (a) ;

    if (a < 0) then begin

    s : = s + a;

    inc (count) ;

    end;

    end;

    writeln (s/count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите среднее арифметическое отрицательных чисел из n введенных. (в паскале) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (2)
Написать программы на Паскале. 1. Вычислить. X - натуральное число. 2. Среди 10 введённых с клавиатуры чисел подсчитать количество отрицательных и произведение положительных. Рассмотреть случай если отрицательных чисел нет.
Ответы (1)
Это в Паскале. Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел, количество которых заранее не известно.
Ответы (1)
1. Найти среднее арифметическое двузначных чисел кратных 7 2. Найти среднее арифметическое первых 10 чисел делящихся на 5 (в паскале)
Ответы (1)
Найти среднее арифметическое N-чисел, введенных с клавиатуры, кратных 3 и 5 одновременно. В паскале.
Ответы (1)